Information Exposure Affecting openssl package, versions >=1.0.200, <1.0.205


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471033

  • published

    2 Oct 2019

  • disclosed

    3 Dec 2015

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.205 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Information Exposure. OpenSSL is vulnerable to information disclosure. The library contains a carry propagation bug during the montgomery squaring procedure. This makes it easier for a malicious user to obtain sensitive private key information from the Diffie-Hellman and Diffie-Hellman Ephemereal Ciphersuites.