Code Affecting openssl Open this link in a new tab package, versions >=1.0.0, <1.0.201


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471034

  • published

    2 Oct 2019

  • disclosed

    18 Nov 2014

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.201 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Code. OpenSSL is vulnerable to denial of service (DoS) attacks. These attacks are possible because OpenSSL does not reinitialize the CHOICE and ADB data structures, allowing attackers to cause invalid write operations and memory corruption through an application that relies on ASN.1 structure reuse.