Resource Management Errors Affecting openssl package, versions >=1.0.0, <1.0.109


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471038

  • published

    2 Oct 2019

  • disclosed

    14 May 2014

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.109 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Resource Management Errors. OpenSSL is vulnerable to denial of service (DoS) through memory consumption. This can be triggered through a DTLS handshake method which forces OpenSSL to process a large amount of data, exhausting the memory.

References