Out-of-Bounds Affecting openssl Open this link in a new tab package, versions >=1.0.200, <1.0.211 >=, <1.0.205

  • Attack Complexity


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    2 Oct 2019

  • disclosed

    28 Aug 2017

  • credit


How to fix?

Upgrade OpenSSL to version 1.0.211, 1.0.205 or higher.


OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-Bounds. OpenSSL is vulnerable to buffer overreads. Attackers can cause a on-byte buffer overread by using a X.509 certificate with a malformed IPAddressFamily extension, as a result the certificate would incorrectly be displayed in clear text.