Out-of-bounds Read Affecting openssl Open this link in a new tab package, versions >=1.0.0, <1.0.211 >=1.0.204.1, <1.0.210


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471048

  • published

    2 Oct 2019

  • disclosed

    26 Jan 2017

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.211, 1.0.210 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-bounds Read. OpenSSL is vulnerable to denial of service (DoS) attacks. The vulnerability exists when a truncated packet causes an out-of-bounds (OOB) read on an SSL/TLS server/client on a 32-bit host using a specific cipher such as CHACHA20/POLY1305 or RC4-MD5 cipher.