Resource Management Errors Affecting openssl package, versions >=1.0.1, <1.0.200


0.0
medium

Snyk CVSS

    Attack Complexity Low
NVD  medium
RHEL  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENSSL-471054
  • published 2 Oct 2019
  • disclosed 11 May 2015
  • credit Unknown

How to fix?

Upgrade OpenSSL to version 1.0.200 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Resource Management Errors. OpenSSL is vulnerable to denial of service (DoS) attacks. A malicious user can pass an unrecognized X.660 OID to the hash function to the system to cause an infinite loop that can cause the system to crash.

References