Information Exposure Affecting openssl package, versions >=1.0.200, <1.0.205


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
5.3 medium
Expand this section
RHEL
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENSSL-471055
  • published 2 Oct 2019
  • disclosed 3 Dec 2015
  • credit Unknown

How to fix?

Upgrade OpenSSL to version 1.0.205 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Information Exposure. OpenSSL is vulnerable to denial of service (DoS) attacks. A malicious user can pass malformed PKCS#7 or CMS data to the server that can cause a memory leak that can lead to the system crashing.