Code Affecting openssl Open this link in a new tab package, versions >=1.0.0, <1.0.201


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471056

  • published

    2 Oct 2019

  • disclosed

    18 Nov 2014

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.201 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Code. OpenSSL is vulnerable to denial of service (DoS) attacks. These attacks are possible because the ASN1_TYPE_cmp function doesn't correctly perform boolean-type comparisons allowing attacks to trigger invalid read operation and application crash through the use of an X.509 certificates.

References