Cryptographic Issues Affecting openssl package, versions >=1.0.0, <1.0.111


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471061

  • published

    2 Oct 2019

  • disclosed

    24 Oct 2014

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.111 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Cryptographic Issues. OpenSSL is vulnerable to ECDHE-to-ECDH downgrade attacks. This is due to a flaw in ssl3_get_key_exchange which allows attackers to trigger a loss of forward secrecy to omitting the ServerKeyExchange message.