Resource Management Errors Affecting openssl package, versions >=1.0.0, <1.0.202


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471136

  • published

    2 Oct 2019

  • disclosed

    17 Feb 2015

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.202 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Resource Management Errors. OpenSSL is vulnerable to denial of service (DoS) attacks. These attacks are possible because it does not correctly handle ECParameter structures where the curve is over a malformed binary polynomial field. These attacks can be triggered through a session that uses an Elliptic Curve algorithm.

References