Information Exposure Affecting openssl package, versions >=1.0.0, <1.0.109


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471180

  • published

    2 Oct 2019

  • disclosed

    14 May 2014

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.109 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Information Exposure. OpenSSL is vulnerable to information disclosure. When pretty printing through the OBJ_obj2txt function in crypto/objects/obj_dat.c is it possible for attackers to read from the process stack memory. This is caused because OpenSSL does not ensure the presence of \0 characters.

References