Man-in-the-Middle (MitM) Affecting openssl package, versions >=1.0.1, <1.0.109


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
NVD  medium
RHEL  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENSSL-471181
  • published 2 Oct 2019
  • disclosed 14 May 2014
  • credit Unknown

How to fix?

Upgrade OpenSSL to version 1.0.109 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Man-in-the-Middle (MitM). OpenSSL is vulnerable to man in the middle (MitM) attacks. These attacks are possible through the ssl23_get_client_hello function in s23_srvr.c. It can be triggered by a ClientHello message fragment which forces OpenSSL to negotiate using the TLS 1.0 protocol insteadl of a higher, more secure version.

References