Information Exposure Affecting openssl package, versions >=1.0.1, <1.0.201


0.0
medium

Snyk CVSS

    Attack Complexity High
    Confidentiality High
Expand this section
NVD
5.9 medium
RHEL  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENSSL-471182
  • published 2 Oct 2019
  • disclosed 1 Mar 2016
  • credit Unknown

How to fix?

Upgrade OpenSSL to version 1.0.201 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Information Exposure. OpenSSL is vulnerable to padding oracle attacks. A malicious user can use an SSLv2 server as a Bleichenbacher oracle, allowing the malicious user to decrypt TLS ciphertext data.