Cryptographic Issues Affecting openssl package, versions >=1.0.0, <1.0.111


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471307

  • published

    2 Oct 2019

  • disclosed

    14 Oct 2014

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.111 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Cryptographic Issues. OpenSSL is vulnerable to brute-force decryption attacks and RSA-to-EXPORT_RSA downgrade attacks. These attacks are possible through the ssl3_get_key_exchange function which offers a weak ephemeral RSA key in a noncompliant role, related to the "FREAK" issue.