Numeric Errors Affecting openssl Open this link in a new tab package, versions >=1.0.1, <1.0.200 >=1.0.204.1, <1.0.209


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471316

  • published

    2 Oct 2019

  • disclosed

    29 Jan 2016

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.200, 1.0.209 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Numeric Errors. OpenSSL is vulnerable to Denial of Service (DoS) attacks. A malicious user can send a new epoch number together with a large sequence number to the server, causing the system to reject additional packets sent via DTLS to the server.