Information Exposure Affecting openssl Open this link in a new tab package, versions >=1.0.200, <1.0.211


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471318

  • published

    2 Oct 2019

  • disclosed

    2 Nov 2017

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.211 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Information Exposure. OpenSSL is vulnerable to a carry propagation issue with the x86_64 Montgomery squaring procedure. This attack can be carried out against unpatched systems using a target private key with persistent DH parameters and a private key which is shared with multiple clients. This could in some circumstances lead to information disclosure as it makes it easier to deduce information about the private key.

This only affects processors that support the BMI1, BMI2 and ADX extensions like Intel Broadwell (5th generation) and later or AMD Ryzen.