Cryptographic Issues Affecting openssl package, versions >=1.0.200, <1.0.208


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471320

  • published

    2 Oct 2019

  • disclosed

    3 May 2016

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.208 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Cryptographic Issues. OpenSSL is vulnerable to padding oracle attacks. The library does not check if there is enough data in both the MAC hash and padding bytes, allowing an attacker to recover the plain text by using the server as a padding oracle.

Note: This vulnerability exists because of an incorrect fix for CVE-2013-0169.