Key Management Errors Affecting openssl Open this link in a new tab package, versions >=1.0.200, <1.0.211


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471322

  • published

    2 Oct 2019

  • disclosed

    11 Jan 2017

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.211 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Key Management Errors. OpenSSL is vulnerable to a cache-timing attack. The attack exists due to a flaw in signing function of crypto/ecdsa/ecdsa_ossl.c which sets the BN_FLG_CONSTTIME flag for nonces instead of taking a secure code path in the BN_mod_inverse method.