Information Exposure Affecting openssl package, versions >=1.0.1, <1.0.200 >=1.0.204.1, <1.0.210


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
5.5 medium
Expand this section
RHEL
5.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENSSL-471329
  • published 2 Oct 2019
  • disclosed 29 Jan 2016
  • credit Unknown

How to fix?

Upgrade OpenSSL to version 1.0.200, 1.0.210 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Information Exposure. OpenSSL is vulnerable to timing attacks. Certain cryptographic functions do not run in constant time, meaning that a malicious user can recover a DSA private key based on the time taken for the operations.