Resource Management Errors Affecting openssl package, versions >=1.0.1, <1.0.200 >=1.0.204.1, <1.0.208


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471331

  • published

    2 Oct 2019

  • disclosed

    3 May 2016

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.200, 1.0.208 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Resource Management Errors. OpenSSL is vulnerable to denial of service (DoS) attacks. The library mishandles invalid ASN.1 encoding and causes large amounts of memory being consumed. A malicious user can take advantage of this to cause a denial of service via resource consumption.