Out-of-bounds Read Affecting openssl package, versions >=1.0.2, <1.0.209


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-471334

  • published

    2 Oct 2019

  • disclosed

    29 Jan 2016

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.209 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-bounds Read. OpenSSL is vulnerable to denial of service (DoS) attacks. A malicious user can create a malicious time-stamp file that is mishandled by the system to cause out of bound reads which can lead to the system crashing.