Use After Free Affecting sqlite3 package, versions >=3.25.0, <3.28.0


0.0
high

Snyk CVSS

    Attack Complexity High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 11.2% (95th percentile)
Expand this section
NVD
8.1 high
Expand this section
Red Hat
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-SQLITE3-470662
  • published 2 Oct 2019
  • disclosed 22 Feb 2019
  • credit Unknown

How to fix?

Upgrade sqlite3 to version 3.28.0 or higher.

Overview

sqlite3 is an embedded SQL database engine

Affected versions of this package are vulnerable to Use After Free sqlite3 is vulnerable to denial of service. A malicious SQL command can cause a use-after-free bug that results in a denial of service condition and could potentially allow an attacker to execute arbitrary code.