SSL Certificate Bypass Affecting starscream package, versions <2.0.4


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-STARSCREAM-472116
  • published 9 Oct 2019
  • disclosed 6 Apr 2017
  • credit Unknown

How to fix?

Upgrade Starscream to version 2.0.4 or higher.

Overview

Starscream is a conforming WebSocket (RFC 6455) client library in Swift.

Affected versions of this package are vulnerable to SSL Certificate Bypass. WebSocket.swift allows an SSL Pinning bypass because pinning occurs in the stream function (this is too late; pinning should occur in the initStreamsWithData function).