Integer Overflow or Wraparound Affecting swiftniohttp2 package, versions <1.19.2


Severity

Recommended
0.0
high
0
10

CVSS assessment made by Snyk's Security Team

    Threat Intelligence

    EPSS
    0.09% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-SWIFTNIOHTTP2-5721883
  • published 6 Nov 2022
  • disclosed 3 Nov 2022
  • credit OSS-Fuzz

How to fix?

Upgrade SwiftNIOHTTP2 to version 1.19.2 or higher.

Overview

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. This can result in a DoS, caused by a network peer sending a specially crafted HPACK-encoded header block.

References

CVSS Scores

version 3.1
Expand this section

Snyk

7.5 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    None
  • Integrity (I)
    None
  • Availability (A)
    High
Expand this section

NVD

7.5 high