Improper Certificate Validation Affecting twitterkit Open this link in a new tab package, versions >=0.0.0


0.0
high
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-TWITTERKIT-2636564

  • published

    26 Jan 2022

  • disclosed

    7 Oct 2019

  • credit

    Unknown

How to fix?

There is no fixed version for TwitterKit.

Overview

TwitterKit is a native SDK to include Twitter content in mobile apps.

Affected versions of this package are vulnerable to Improper Certificate Validation. The Twitter Kit framework through 3.4.2 for iOS does not properly validate the api.twitter.com SSL certificate. Although the certificate chain must contain one of a set of pinned certificates, there are certain implementation errors such as a lack of hostname verification. NOTE: this is an end-of-life product.

References