Out-of-Bounds Affecting yaml-cpp Open this link in a new tab package, versions >0.0.0


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-YAMLCPP-471234

  • published

    2 Oct 2019

  • disclosed

    3 Apr 2017

  • credit

    Kamil Frankowicz

How to fix?

There is no fixed version for yaml-cpp.

Overview

yaml-cpp is a YAML parser and emitter in C++.

Affected versions of this package are vulnerable to Out-of-Bounds. The attacks are possible because the SingleDocParser::HandleNode() function does not handle YAML files properly, allowing the attackers to trigger stack consumption and application crash using malicious YAML files.