Out-of-bounds Write Affecting libmediainfo package, versions [,21.03)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.87% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Write vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-CONAN-LIBMEDIAINFO-10076661
  • published8 May 2025
  • disclosed18 Mar 2021
  • creditUnknown

Introduced: 18 Mar 2021

CVE-2020-26797  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade libmediainfo to version 21.03 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. Mediainfo before version 20.08 has a heap buffer overflow vulnerability via MediaInfoLib::File_Gxf::ChooseParser_ChannelGrouping.

References

CVSS Base Scores

version 3.1