Denial of Service (DoS) Affecting lua package, versions [,5.4.1)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.55% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CONAN-LUA-10077600
  • published8 May 2025
  • disclosed24 Jul 2020
  • creditUnknown

Introduced: 24 Jul 2020

CVE-2020-15945  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade lua to version 5.4.1 or higher.

Overview

Affected versions of this package are vulnerable to Denial of Service (DoS). Lua through 5.4.0 has a segmentation fault in changedline in ldebug.c (e.g., when called by luaG_traceexec) because it incorrectly expects that an oldpc value is always updated upon a return of the flow of control to a function.

References

CVSS Base Scores

version 3.1