Out-of-bounds Read Affecting luajit package, versions [,2.1.1792527110)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.13% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Read vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-CONAN-LUAJIT-10077611
  • published8 May 2025
  • disclosed21 Jul 2020
  • creditUnknown

Introduced: 21 Jul 2020

CVE-2020-15890  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade luajit to version 2.1.1792527110 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Read. LuaJit through 2.1.0-beta3 has an out-of-bounds read because __gc handler frame traversal is mishandled.

CVSS Base Scores

version 3.1