Deserialization of Untrusted Data Affecting apache-log4j2 Open this link in a new tab package, versions <2.15.0-1~deb10u1

  • Exploit Maturity


  • Attack Complexity


  • Scope


  • Confidentiality


  • Integrity


  • Availability


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    10 Dec 2021

  • disclosed

    10 Dec 2021

How to fix?

Upgrade Debian:10 apache-log4j2 to version 2.15.0-1~deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream apache-log4j2 package. See How to fix? for Debian:10 relevant versions.

Apache Log4j2 2.0-beta9 through 2.15.0 (excluding security releases 2.12.2, 2.12.3, and 2.3.1) JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled. From log4j 2.15.0, this behavior has been disabled by default. From version 2.16.0 (along with 2.12.2, 2.12.3, and 2.3.1), this functionality has been completely removed. Note that this vulnerability is specific to log4j-core and does not affect log4net, log4cxx, or other Apache Logging Services projects.