CVE-2016-1900 Affecting cgit package, versions <0.11.2.git2.3.2-1.1


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.94% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-CGIT-275006
  • published20 Jan 2016
  • disclosed20 Jan 2016

Introduced: 20 Jan 2016

CVE-2016-1900  (opens in a new tab)

How to fix?

Upgrade Debian:10 cgit to version 0.11.2.git2.3.2-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cgit package and not the cgit package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

CRLF injection vulnerability in the cgit_print_http_headers function in ui-shared.c in CGit before 0.12 allows remote attackers with permission to write to a repository to inject arbitrary HTTP headers and conduct HTTP response splitting attacks or cross-site scripting (XSS) attacks via newline characters in a filename.