Access Restriction Bypass Affecting chef package, versions <0.10.10-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.42% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-CHEF-340082
  • published8 Aug 2012
  • disclosed8 Aug 2012

Introduced: 8 Aug 2012

CVE-2011-5097  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Debian:10 chef to version 0.10.10-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream chef package and not the chef package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

chef-server-api/app/controllers/cookbooks.rb in Chef Server in Chef before 0.9.18, and 0.10.x before 0.10.2, does not require administrative privileges for the update and destroy methods, which allows remote authenticated users to (1) upload cookbooks via a knife cookbook upload command or (2) delete cookbooks via a knife cookbook delete command.

CVSS Base Scores

version 3.1