CVE-2020-8284 Affecting curl package, versions <7.64.0-4+deb10u2


0.0
low

Snyk CVSS

    Attack Complexity High
Expand this section
RHEL
3.1 low
Expand this section
SUSE
4.3 medium
Expand this section
NVD
3.7 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-CURL-1049501
  • published 9 Dec 2020
  • disclosed 14 Dec 2020

How to fix?

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See How to fix? for Debian:10 relevant versions.

A malicious server can use the FTP PASV response to trick curl 7.73.0 and earlier into connecting back to a given IP address and port, and this way potentially make curl extract information about services that are otherwise private and not disclosed, for example doing port scanning and service banner extractions.