Out-of-bounds Write Affecting curl package, versions <7.64.0-4+deb10u2


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
Red Hat
6.5 medium
Expand this section
SUSE
6.5 medium
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-CURL-1049502
  • published 9 Dec 2020
  • disclosed 14 Dec 2020

How to fix?

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See How to fix? for Debian:10 relevant versions.

curl 7.21.0 to and including 7.73.0 is vulnerable to uncontrolled recursion due to a stack overflow issue in FTP wildcard match parsing.