Improper Certificate Validation Affecting curl package, versions <7.64.0-4+deb10u2


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High
Expand this section
NVD
7.5 high
Expand this section
Red Hat
7.4 high
Expand this section
SUSE
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-CURL-1049506
  • published 9 Dec 2020
  • disclosed 14 Dec 2020

How to fix?

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See How to fix? for Debian:10 relevant versions.

curl 7.41.0 through 7.73.0 is vulnerable to an improper check for certificate revocation due to insufficient verification of the OCSP response.