Information Exposure Affecting curl package, versions <7.64.0-4+deb10u2


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
Red Hat
5.9 medium
Expand this section
SUSE
5.3 medium
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-CURL-573153
  • published 24 Jun 2020
  • disclosed 14 Dec 2020

How to fix?

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See How to fix? for Debian:10 relevant versions.

curl 7.62.0 through 7.70.0 is vulnerable to an information disclosure vulnerability that can lead to a partial password being leaked over the network and to the DNS server(s).