OS Command Injection Affecting evince package, versions <3.25.92-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.36% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-EVINCE-6156009
  • published14 Jan 2024
  • disclosed12 Jan 2024

Introduced: 12 Jan 2024

CVE-2023-51698  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Debian:10 evince to version 3.25.92-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream evince package and not the evince package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

Atril is a simple multi-page document viewer. Atril is vulnerable to a critical Command Injection Vulnerability. This vulnerability gives the attacker immediate access to the target system when the target user opens a crafted document or clicks on a crafted link/URL using a maliciously crafted CBT document which is a TAR archive. A patch is available at commit ce41df6.

CVSS Base Scores

version 3.1