Double Free Affecting fontconfig package, versions <2.11.0-6.5


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.4% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-FONTCONFIG-310713
  • published13 Aug 2016
  • disclosed13 Aug 2016

Introduced: 13 Aug 2016

CVE-2016-5384  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Debian:10 fontconfig to version 2.11.0-6.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fontconfig package and not the fontconfig package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

fontconfig before 2.12.1 does not validate offsets, which allows local users to trigger arbitrary free calls and consequently conduct double free attacks and execute arbitrary code via a crafted cache file.

CVSS Base Scores

version 3.1