Access Restriction Bypass Affecting glance package, versions <2012.1.1-2


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
5.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-GLANCE-313235
  • published 11 Nov 2012
  • disclosed 11 Nov 2012

How to fix?

Upgrade Debian:10 glance to version 2012.1.1-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glance package and not the glance package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

The v1 API in OpenStack Glance Grizzly, Folsom (2012.2), and Essex (2012.1) allows remote authenticated users to delete arbitrary non-protected images via an image deletion request, a different vulnerability than CVE-2012-5482.