Information Exposure Affecting glance package, versions <2015.1.0-4



    Attack Complexity Low
    User Interaction Required
Expand this section
3.5 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-GLANCE-313280
  • published 19 Aug 2015
  • disclosed 19 Aug 2015

How to fix?

Upgrade Debian:10 glance to version 2015.1.0-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glance package and not the glance package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

The import task action in OpenStack Image Service (Glance) 2015.1.x before 2015.1.2 (kilo), when using the V2 API, allows remote authenticated users to read arbitrary files via a crafted backing file for a qcow2 image.