Loop with Unreachable Exit Condition ('Infinite Loop') Affecting glibc package, versions *


low
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DEBIAN10-GLIBC-1035462

  • published

    3 Nov 2020

  • disclosed

    26 Feb 2021

How to fix?

There is no fixed version for Debian:10 glibc.

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid multi-byte input sequences in IBM1364, IBM1371, IBM1388, IBM1390, and IBM1399 encodings, fails to advance the input state, which could lead to an infinite loop in applications, resulting in a denial of service, a different vulnerability from CVE-2016-10228.