Cross-site Scripting (XSS) Affecting icinga package, versions <1.13.3-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.49% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-ICINGA-324545
  • published27 Mar 2017
  • disclosed27 Mar 2017

Introduced: 27 Mar 2017

CVE-2015-8010  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:10 icinga to version 1.13.3-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream icinga package and not the icinga package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in the Classic-UI with the CSV export link and pagination feature in Icinga before 1.14 allows remote attackers to inject arbitrary web script or HTML via the query string to cgi-bin/status.cgi.