Improper Input Validation Affecting libgdata package, versions <0.10.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.9% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-LIBGDATA-289469
  • published26 Aug 2012
  • disclosed26 Aug 2012

Introduced: 26 Aug 2012

CVE-2012-1177  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:10 libgdata to version 0.10.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgdata package and not the libgdata package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

libgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows remote attackers to obtain user names and passwords via a man-in-the-middle (MITM) attack with a spoofed certificate.

CVSS Base Scores

version 3.1