Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') Affecting libhibernate-validator-java Open this link in a new tab package, versions <4.3.3-4

  • Attack Complexity


  • Confidentiality


  • Integrity


  • Availability


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    10 Jan 2018

  • disclosed

    10 Jan 2018

How to fix?

Upgrade Debian:10 libhibernate-validator-java to version 4.3.3-4 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream libhibernate-validator-java package. See How to fix? for Debian:10 relevant versions.

In Hibernate Validator 5.2.x before 5.2.5 final, 5.3.x, and 5.4.x, it was found that when the security manager's reflective permissions, which allows it to access the private members of the class, are granted to Hibernate Validator, a potential privilege escalation can occur. By allowing the calling code to access those private members without the permission an attacker may be able to validate an invalid instance and access the private member value via ConstraintViolation#getInvalidValue().