Out-of-Bounds Affecting libpng1.6 package, versions <1.6.20-1


0.0
high

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
7.3 high
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-LIBPNG16-296453
  • published 21 Jan 2016
  • disclosed 21 Jan 2016

How to fix?

Upgrade Debian:10 libpng1.6 to version 1.6.20-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpng1.6 package and not the libpng1.6 package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

Buffer overflow in the png_set_PLTE function in libpng before 1.0.65, 1.1.x and 1.2.x before 1.2.55, 1.3.x, 1.4.x before 1.4.18, 1.5.x before 1.5.25, and 1.6.x before 1.6.20 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a small bit-depth value in an IHDR (aka image header) chunk in a PNG image. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-8126.