Out-of-Bounds Affecting libpng1.6 package, versions <1.6.16-1


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
NVD  critical
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-LIBPNG16-296456
  • published 10 Jan 2015
  • disclosed 10 Jan 2015

How to fix?

Upgrade Debian:10 libpng1.6 to version 1.6.16-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpng1.6 package and not the libpng1.6 package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

Heap-based buffer overflow in the png_combine_row function in libpng before 1.5.21 and 1.6.x before 1.6.16, when running on 64-bit systems, might allow context-dependent attackers to execute arbitrary code via a "very wide interlaced" PNG image.