Numeric Errors Affecting libpng1.6 package, versions <1.6.10-1


0.0
medium

Snyk CVSS

    Attack Complexity Low
NVD  medium
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-LIBPNG16-296459
  • published 27 Feb 2014
  • disclosed 27 Feb 2014

How to fix?

Upgrade Debian:10 libpng1.6 to version 1.6.10-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpng1.6 package and not the libpng1.6 package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

The png_push_read_chunk function in pngpread.c in the progressive decoder in libpng 1.6.x through 1.6.9 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via an IDAT chunk with a length of zero.