Numeric Errors Affecting libpng1.6 package, versions <1.6.10-1


0.0
medium

Snyk CVSS

    Attack Complexity Low
NVD  medium
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-LIBPNG16-296465
  • published 6 May 2014
  • disclosed 6 May 2014

How to fix?

Upgrade Debian:10 libpng1.6 to version 1.6.10-1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream libpng1.6 package. See How to fix? for Debian:10 relevant versions.

Multiple integer overflows in libpng before 1.5.14rc03 allow remote attackers to cause a denial of service (crash) via a crafted image to the (1) png_set_sPLT or (2) png_set_text_2 function, which triggers a heap-based buffer overflow.