Numeric Errors Affecting libpng1.6 package, versions <1.6.10-1



    Attack Complexity Low
NVD  medium
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-LIBPNG16-296474
  • published 6 May 2014
  • disclosed 6 May 2014

How to fix?

Upgrade Debian:10 libpng1.6 to version 1.6.10-1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream libpng1.6 package. See How to fix? for Debian:10 relevant versions.

Integer overflow in the png_set_unknown_chunks function in libpng/pngset.c in libpng before 1.5.14beta08 allows context-dependent attackers to cause a denial of service (segmentation fault and crash) via a crafted image, which triggers a heap-based buffer overflow.