Improper Input Validation Affecting libpng1.6 package, versions <1.6.32-1


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical
Expand this section
Red Hat
3.7 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-LIBPNG16-453126
  • published 24 Jul 2019
  • disclosed 10 Jul 2019

How to fix?

Upgrade Debian:10 libpng1.6 to version 1.6.32-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpng1.6 package and not the libpng1.6 package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

libpng before 1.6.32 does not properly check the length of chunks against the user limit.